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  مقدمه
ايجاد  online  محاوره اي تا دوره هاي آموزشيامكان مي دهد  به شما  macromedia flash mxآموزش تعاملي 

 دارد  زيادي داردمزاياي macromedia flashاستفاده از آموزش تعاملي  . اجرا مي شوند macromedia flashكنيد كه در 
   :كه تعدادي از آنها عبارتند از 

 مي تواند از مضمون آموزشي اي كه شما ايجاد  macromedia flashر كسي با يك مرورگر وب داراي قابليت ه •
 .كرده ايد استفاده كند

به دليل استفاده از  .  بصورت شخصي ايجاد كنيدشما مي توانيد رابطي را كه با نيازتان مطابقت داشته باشد •
macromedia flash مرورگرهايبا كيفيت بالا بسازيد كه سريع بارگذاري مي شود و ودر  ، شما مي توانيد رابطهايي 

 .به يك صورت ديده مي شودمختلف 

 به دوره آموزشي  macromedia flashبا استفاده از اجزاي تعاملي مربوط به  شما به سادگي مي توانيد تعامل را  •
onlineبدون نوشتن كد ارائه مي دهيد  ، بطوريكه يك رابط ساده براي ورود داده ها  تان اضافه كنيد . 

اطلاعات رد يابي را براي يك سيستم مديريت آموزش همراه با  مي تواند macromedia flashهر آموزش تعاملي  •
 .مطابقت دارد )AICC( كه با قوانين انجمن صنعت آموزش بر اساس كامپيوتر  بفرستد)LMS(سرور

 آزمايش مي كند و مي تواند آنها را با  ، يك سلسله از تعاملاتدر مجموع ، الگوهاي رديابي نتايج تراكمي را از •
 استاندارد باو هم  AICC  استاندارد با انتقال دهد كه هم LMSاستفاده ازعوامل رديابي داده هاي افزايش يافته ، موازي با 

 . داردمطابقت) SCORM  (مدل مرجع اشياء قابل اشتراك گذاري 

  شروع
  را روي macromedia flash mx  ، شما نياز داريد كه  macromedia flashتعاملي براي استفاده از آموزش 

روي (  قابل دسترسي است com.macromedia.www از طريق سايت mxacromedia flashM . كنيدكامپيوترتان نصب 
   .  ) كليك كنيد storeلينك 

   macromedia flash و مرورگر وب داراي قابليت flash player 6 شما روي هر كامپيوتري با نرم افزار آموزشي
  .اجرا خواهد شد  

 سيستم   داشته باشيد ، مثل يكLMS ، شما بايد يك  macromedia flashبراي رديابي داده كاربر از آموزش تعاملي
 يا netscape navigator 4.0 يا internet explorer 4.0كاربران بايد  در مجموع ، . SCORM يا AICCسازگار با 

 internet با آموزش تعاملي LMSرديابي در يك . داشته باشند) مكينتاش( يا بالاتر  netscape 4.5و يا ) ويندوز(بالاتر

explorer در مكينتاش كار نمي كند .  

    Macromedia Flashدرباره  آموزش تعاملي
اين تعامل .  بر روي فيلم متقابلا اثر بگذارد  ،ست كه به كاربر اجازه مي دهد با ارائه پاسخيك تعامل بخشي از يك فيلم ا

شما از شش نوع تعامل آموزشي زير كه در . ممكن است بخشي از يك آزمون يا يك نمونه آموزشي ديگر باشد 
macromedia flash mxد  وجود دارد مي توانيد براي برنامه آموزشي تان استفاده كني:  

  .در اين نوع تعامل ، كاربر به يك سؤال صحيح يا غلط پاسخ مي دهد:  (True or False) صحيح يا غلط  
  . پاسخ مي دهد گزينه اي كاربر به يك سؤال چند  : (Multiple Choice) گزينه ايچند 
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ي كند  و سپس يك پاسخ كاربر ابتدا پاسخ را با عبارتهاي مشابه روبرويش چك م  : (Fill in the Blank) جاي خالي
  .را تايپ مي كند

مقصد به يك كاربر با كشيدن يك يا چند شييء روي صفحه به سمت   : (Drag And Drop) كشيدن و رها كردني
  .سؤال پاسخ ميدهد

   .روي صفحه به سؤال پاسخ مي دهد) يا نواحي(كاربر با كليك كردن بر روي يك ناحيه  : (Hot Spot)   نقطه حساس
روي صفحه به سؤال پاسخ مي ) يا اشياء(كاربر با كليك كردن بر روي يك شيء  : (Hot Object) اس شيء حس

  . دهد
هر يك از تعاملات آموزشي پارامترهاي منحصر به فردي دارند كه تعيين مي كنند كه چگونه تعامل براي كاربر ظاهر 

 macromediaكه انجام وظايف و پيكربندي يك سند  هستند ، بطوري macromedia flash تعاملات از اجزاي .خواهد شد 

flash  مي كنندساده تر را .  

    Macromedia Flashاستفاده از تعاملات آموزشي 
  :  دو روش وجود دارد  macromedia flash mx از تعاملات آموزشي  استفادهبراي

رديابي آنها لازم است نين براي همچو هستند  ما مورد نياز  كه سؤالاتيبراي ي كهالگوهاي آزموناستفاده از •
تعاملات آموزشي مربوط به آزمون بصورت گرافيكي و طوري طراحي شده اند كه براي قالب آزمون . طراحي شده اند 

 APIد و رديابي هاي مورد نياز در ن  را محاسبه مي كنكليالگوهاي آزمون شامل مكانيزمي هستند كه رتبه . مناسب باشند
  . انجام مي دهندرا SCORM   وAICCهاي  

 كه نياز به قرار ي مورد نياز است ، يا يك سري از تعاملاتبه تنهايي براي مواقعي كه يك تعامل تكي ،تعاملات  •
 دسترس آنها از كتابخانه عمومي قابل.  اند طراحي شده ، دارند macromedia flashگرفتن در يك طرح بندي خاص در سند 

شما مي توانيد براي هر تعامل تكي منحصربفرد نتايج را . بصورت گرافيكي طراحي شده اند  ي وهستند و براي استفاده تك
 .  ارائه كنيد AICC با قابليت LMSبررسي كنيد و آن را به يك 

  . ، شما بايد از يك الگوي آزمون استفاده كنيد SCORM رديابي استفاده ازبراي 
  استفاده از الگوهاي آزمون

آموزشي مون براي اين امر تنظيم شده اند كه به شما اجازه بدهند تا به سادگي بتوانيد دوره هاي هر يك از الگوهاي آز
الگوهاي آزمون يكسري راهنمايي .  استفاده مي شوند را بسازيد  macromedia flashچندقسمتي كه در تعاملات آموزشي 

اطلاعات  هستند كه مي توانند Action Scriptن شامل آنها همچني. هاي داخلي پيشرفته را در بين تعاملات ارائه مي دهند 
  .رديابي را براي يك وب سرور بفرستند

شما مي توانيد بلافاصله آزمون  بعد از ايجاد يك سند با استفاده از الگوي آزمون ،. الگوهاي آزمون كاملا تابعي هستند 
ش نوع تعامل آموزشي وجود دارد كه در كتابخانه  آن را در عمل ببينيد ، همراه يك آزمون ش نحوه كاررا تست كنيد تا

 كه هر تعامل را مي هستنداز عناصر  ساده اي اي هاين كليپهاي فيلم شامل مجموعه .بصورت كليپهاي فيلم ذخيره شده اند 
 Break(تعامل آموزشي را به صحنه اضافه كرديد ،بايد آن را جداسازي مربوط به بعد از اينكه شما يك كليپ فيلم . سازند 

Apart(  ويرايش كنيد هر قسمت راكنيد و سپس مي توانيد .  
 متفاوت گرافيكي از نظر وجود دارد، كه هر كدام  macromedia flashسه الگوي آزمون براي تعاملات آموزشي در 

   :مي باشندعناصر زير همه آنها شامل . به طور كلي يك كار را انجام مي دهنداما  ديده مي شوند ،
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 ه خوش آمد گويييك صفح •

 يكي از شش نوع تعامل آموزشي •

 يك صفحه نتايج  •

 عناصر راهنما •

• Action Script براي جمع آوري اطلاعات رديابي AICC و SCORM 

  :براي ايجاد آزمون 
  .  ايجاد كنيد file>new from templateيك فايل جديد با استفاده از  -1
 را انتخاب كنيد ، سپس يكي از آزمونهاي quiz گزينه category ، از ستون new documentدر پنجره  -2

 .انتخاب كنيد  Category Itemsنمونه را از ستون 

   

   
  

 اشاره گر ماوس را روي نام   اما قالبهاي انتخابي متفاوتي را ارائه مي دهند ، ،آزمون ها از نظر محتوا يكسان هستند
  .الگو قرار دهيد تا پيش نمايش قالب را مشاهده كنيد 

 استفاده file>save بار اولي كه از  macromedia flash به دليل اينكه سند از روي يك الگو ايجاد شده است ، : هنكت
  .مي كنيد از شما درباره ذخيره يك كپي از سند خواهد پرسيد 

  . كليك كنيد createروي  -3
  . ظاهر خواهند شد Timeline لايه هاي آزمون روي  وآزمون و همه تعاملاتش روي صحنه ظاهر خواهند شد

  تنظيم پارامترهاي آزمون
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كاربر را كنترل مي كنند  اين پارامترها چگونگي ارائه كامل آزمون به .مرحله بعدي تنظيم پارامترهاي آزمون است 
 و صفحه نتايج چگونه نمايش داده LMS اطلاعات رديابي  براي مثال ، سوالات بصورت تصادفي يا ترتيبي ارائه شوند و ،

  .د نشو
  :براي تنظيم كردن پارامترها 

اين كار اجزاي آزمون را انتخاب مي كند و به شما . دستورالعمل ها را انتخاب كنيد ، از سمت چپ صحنه -1
 .اجازه مي دهد تا پارامترها را براي آزمون تنظيم كنيد 

  

  
  .د ناين دستورالعملها در فيلم نهايي ظاهر نمي شو : نكته

  ) window>component parameters. (را باز كنيد  Component Parametersپانل  -2

  

  
  

  .آن را تغيير اندازه دهيد   ، Component Parametersبراي خواناتر شدن پانل    اگر لازم بود ، :نكته 
 را انتخاب كنيد Randomize گزينه در صورتي كه مي خواهيد سوالات آزمون بصورت تصادفي ارائه شود -3

.  
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 ، تعداد سوالاتي را كه در هر ارائه آزمون بايد پرسيده شود مشخص Question to Askدر جعبه متن  -4
، آزمون هميشه از همه سوالاتي كه شما به سند اضافه كرده ايد استفاده خواهد كرد  تنظيم كنيد 0اگر اين گزينه را روي  كنيد ،

تنها تعدادي از سوالات را نمايش خواهد داد كه در اگر شما عددي بزرگتر از تعداد سوالات آزمون وارد نماييد ، آزمون . 
 .آزمون هستند ولي بصورت تكراري استفاده نشده اند 

.  سوال 5شما مي توانيد يك عدد كمتر را قرار دهيد ، مثلا    سوال تعاملي در آزمونتان داريد ،10 اگر شما  براي مثال ،
 استفاده شود براي ايجاد آزموني با سوالات غير Randomize با خصوصيت  همراهاين خصوصيت مخصوصا زماني كه

   . سودمند خواهد بودمنتظره و با ترتيبي غير منتظره
 AICC با قابليت LMS و آزمون از يك   وارد شوند و از آنها آزمون گرفته شود ، اگر شما مي خواهيد كاربران-5 

 log كاربردرصورتيكه مرورگر كاربر را  macromedia flashفيلم . تعيين كنيد خودتان  فايل منطقي را URL  ،گرفته نشود

in  نكرده باشد به اين آدرس هدايت مي كند  .  
را  HTML يك آزمون را آغاز مي كند ، شامل پارامترهايي خواهد بود كه كد AICC با قابليت LMSوقتي كه يك 

بطور مناسب بار گذاري شود آموزشي دوره و  را براي فيلم فلش آغاز كنند EMBEDجستجو مي كنند به طوري كه يك تگ 
 در redirectاين .  را اجرا مي كند redirect فايل منطقي بطور اتوماتيك URLاگر پارامترهاي آغازين موجود نباشد ، . 

  . رخ نمي دهد SCORMالگوهاي 
 در صورتيكه  ،ود را خLMSنام و شناسه فعاليت مربوط به  ، Activity ID و Activity Nameدر جعبه متنهاي  -6

 استفاده نمي كنيد مي توانيد اين جعبه متنها را خالي LMSاز  در صورتيكه. از يكي از آنها استفاده مي كنيد وارد كنيد 
  .بگذاريد 
 Show Results در صورتيكه شما مي خواهيد نتايج آزمون بعد از اتمام آزمون به كاربر نمايش داده شود گزينه -7

Pageكنيد  را انتخاب .  

  قرار دادن تعاملات آموزشي در يك آزمون
  .هر سوال در آزمون يك تعامل در نظر گرفته مي شود 

تعاملات سلسله مراتبي را  وقتي شما از يك الگوي آزمون استفاده مي كنيد ، بين اولين و آخرين فريم از لايه تعاملات ،
 تعاملات فريم ها و فريم هاي كليدي را  مراتب باقيماندهشما ممكن است بر حسب ضرورت در طول سلسله .قرار مي دهيد 

  . اولين و آخرين فريمها براي صفحه خوش آمد گويي و صفحه نتايج رزرو مي شوند  ،اضافه و يا حذف كنيد

  
  

   سوال ،10در يك آزمون با  براي مثال ، 
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 فريم كليدي صفحه خوش آمد گويي= فريم اول  •

 كليدي تعاملاتفريم هاي  = 11 تا 2فريم هاي  •

 فريم كليدي صفحه نتايج  = 12فريم  •

  . فريم كليدي مي شود 12اين حالت در لايه تعاملات بطوركلي شامل 
  :براي قرار دادن تعاملات آموزشي در يك آزمون 

  مدكويي  فريم اول در لايه تعاملات را انتخاب كنيد و هر گونه اصلاحاتي را كه مايل هستيد روي متن صفحه خوش آ-1
 دهد كه براي رفتن به صفحه بعدي بايد  مي كه به كاربر نشانوجود داردمتني در اين صفحه مطمئن شويد كه . انجام دهيد 
  .هيچگونه تعاملي را در اين صفحه اضافه نكنيد .  كليك كندnextروي دكمه 

  : را انجام دهيد شش فريم بعدي انتخاب كنيد و يكي از كارهاي زيرهر يك از تعاملات آموزشي را در  -2
 استفاده "پيكربندي يك تعامل آموزشي"اگر شما مي خواهيد از آن تعامل استفاده كنيد ، از دستورالعملهاي قسمت  •
 .نماييد

 " timelineحذف يك تعامل آموزشي از "از دستورالعملهاي قسمت  اگر شما نمي خواهيد از آن تعامل استفاده كنيد ، •
 .استفاده كنيد 

و هر گونه اصلاحاتي را كه مايل هستيد روي متن صفحه نتايج انجام لات آخرين فريم را انتخاب كنيد تعامدر لايه  -3
اگر . ريد ممكن است نتايج در آنها ظاهر نشوند گذاباقي ب دست نخورده  نامهاي فيلد متن پويا رادقت كنيد كه اگر. دهيد 

 فريم هرگز صدازده نخواهد شد ، اما همچنان رزرو شده باقي مي ماند پارامترهاي صفحه نتايج آزمون را غيرفعال كنيد  ، اين
  .در اين فريم تعاملي قرار ندهيد . 

  پيكربندي يك تعامل آموزشي 
اين . همراه با آزمون يكي از شش نوع تعامل آموزشي وجود دارد ، كه در كليپ فيلم در كتابخانه ذخيره مي شود 

وقتي شما يك كليپ فيلم را به صحنه اضافه مي . ناصر هستند كه هر تعامل را مي سازند شامل مجموعه اي از عكليپهاي فيلم 
  .كنيد ، بايد آن را جداكنيد تا آزادانه بتوانيد آن را طبق نظرخودتان ويرايش كنيد 

  :براي پيكربندي يك تعامل آموزشي 
اين كار تعامل را به . را انتخاب كنيد  modify>break apart ابتدا كل تعامل آموزشي را انتخاب كنيد و سپس  -1

  . عناصري منحصر به فرد كه مي توانند تغيير كنند تبديل مي كند 
تست كردن جداسازي يك  "براي اطلاعات بيشتر به قسمت .  دقت كنيد كه جداسازي را فقط يك بار انجام دهيد : نكته 

  . مراجعه نماييد"كليپ فيلم 
   )ctrl + shift + a. ( از انتخاب خارج كنيد  كل عناصر موجود در صحنه را-2
اين كار باعث مي شود كه اجزاي مربوط به تعامل آموزشي .  دستورالعملهاي موجود در صحنه را انتخاب كنيد -3

  .انتخاب شوند 
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  .اين دستورالعملها در فيلم نهايي ظاهر نمي شوند   :نكته 
4- window>component parametersپانل . نيد  را انتخاب كcomponent parameters براي تعامل آموزشي 

  .ظاهر مي شود 

  
  
 Interaction مي فرستد ، در جعبه متن LMSاطلاعات رديابي را براي يك سرور   macromedia flashاگر فيلم  -5

ID ين كنيد تا به وسيله ما پيشنهاد مي كنيم نام هر تعامل را بصورت منحصربفرد تعي.  يك نام براي تعامل وارد نماييدLMS 
  .تان شناسايي شود 

اين متن ممكن است يك .  را كه مي خواهيد به كاربر نشان داده شود را وارد كنيد متني   ،Questionدر جعبه متن  -6
  .سؤال و يا يك دستورالعمل براي كاربر باشد 

  :بخشهاي زير را بررسي كنيد . تعامل آموزشي را پيكربندي كنيد  -7
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 "كربندي يك تعامل كشيدن و رهاكردني  پي" •

 " پيكربندي يك تعامل پركردن جاي خالي " •

 " پيكربندي يك تعامل شيء حساس " •

 " پيكربندي يك تعامل نقطه حساس " •

 " پيكربندي يك تعامل چند گزينه اي " •

  " پيكربندي يك تعامل صحيح يا غلط " •
  . و بازخورد را براي تعامل آموزشي وارد نماييد  كليك كنيد و پارامترهاي رديابي option buttonروي  -8

اسنادي كه با استفاده از الگوي آزمون ايجاد مي شوند نياز دارند كه رديابي دانش را براي روشن شدن و : نكته 
  .را براي هر تعامل آموزشي تنظيم نمايند  دستورات مربوط به خاموش شدن

  . را براي تعامل آموزشي تغيير دهيد assets  كليك كنيد وassetsروي دكمه ) اختياري  ( -9

  Time Lineافزودن تعاملات آموزشي به 
 خود اضافه كنيد فرايند  macromedia flash را به سند يتكتعاملات  الگوي آزمون استفاده كنيد و چه چه شما از يك

  .  يكسان است Time lineافزودن تعاملات آموزشي به 
 .استفاده مي كنيد ، بايد تعاملات آموزشي را پشت سر هم به لايه تعاملات اضافه كنيد اگر شما از يك الگوي آزمون  •

 هر يك ازشما مي توانيد   كه ساخته ايد اضافه مي كنيد ، macromedia flashاگر شما تعاملات آموزشي را به سند  •
براي ( ا بصورت  فريم هاي پشت سر هم  در يك فريم تكي قرار دهيد ، و از آنه Time lineتعاملات آموزشي تكي را روي  

  . يا فريم هاي برچسب داراستفاده كنيد ،)  فريم پشت سر هم 10 سؤال در 10 مثال ،
   :Time lineبراي افزودن تعامل آموزشي به 

  :  يكي از كارهاي زير را انجام دهيد -1
ؤال قبلي تان است در لايه تعاملات انتخاب شامل ساگر شما از الگوي آزمون استفاده مي كنيد ، فريم كليدي اي را كه  •

 يك فريم خالي بعد از فريم كليدي كه شما  macromedia flash.  را انتخاب كنيد Insert>Blank Keyframeكنيد ، و سپس 
 . انتخاب كرده ايد اضافه مي كند 

انتخاب كنيد و سپس اگر شما تعاملاتي را به سندي كه ايجاد كرده ايد اضافه مي كنيد ، لايه مناسب را  •
Insert>Blank Keyframe را انتخاب كنيد . 

  :يكي از كارهاي زير را انجام دهيد  -2
و سپس پوشه  ) Window>Library( كتابخانه سند را باز كنيد  يك تعامل ديگر به الگوي آزمون ،افزودن براي  •

2_Learning Interactions را باز كنيد . 
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پانل .  را انتخاب كنيد Window>Common Libraries>Learning Interactions ،  يتكبراي افزودن يك تعامل  •

Library-Learning Interactions باز مي شود  . 
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 ، True or False ، Multiple Choice ، Fill in the Blank: شش نوع تعامل آموزشي در كتابخانه وجود دارد 
Drag and Drop ، Hot Spot و Hot Object .  در مجموع ، پوشه هايي برايAssests ، Global Class و Components 

  . ايجاد دستي تعاملات استفاده مي شوند اين پوشه ها براي . وجود دارد 
 هاي تعاملات آموزشي را از پانل Component فريم كليدي اي را كه ايجاد كرده ايد انتخاب كنيد ، سپس يكي از -3

  . درگ كنيد كتابخانه به روي صحنه
  . تعامل را با درگ كردن جابه جا كنيد و آن را در هركجا از صحنه كه دوست داريد قرار دهيد -4
  . تعامل آموزشي را پيكربندي كنيد -5

  Time lineيك تعامل آموزشي از حذف 
. ظ شده است  حذف مي كنيد ، مطمئن شويد كه توالي تعاملات آموزشي حفTime lineوقتي يك تعامل آموزشي را از 

  . اگر يك فريم را از لايه تعاملات حذف مي كنيد مطمئن شويد كه آن را از همه لايه هاي ديگر به خوبي حذف كرده ايد 
  Time lineبراي حذف يك تعامل از 

  . در لايه تعاملات ، فريم كليدي شامل تعامل را كه بايد حذف شود انتخاب كنيد -1
2- Delete يا Backspaceر دهيد  را فشا.  

(  حذف كنيد Time lineشما مي توانيد تعامل ديگري را به اين فريم كليدي اضافه كنيد و يا فريم كليدي را از 
Insert>Remove Frames.(   

مطمئن شويد كه . اضافه و يا حذف مي كنيد باشيد لايه هاي مياني شمارنده فريمهايي كه دقت كنيد كه مواظب   :نكته 
 چنانچه شمارنده فريم در همه فريمهاي مشابه است Time lineدر شماره فريم هاي مشابه در طول هدف همه لايه ها 

  .درست باشد 
   در صورتيكه تكه تكه شده باشد كليپ فيلمآزمايش كردن نحوه ديدن 

 شده است توصيه. انتقال نگه دارنده كليپ فيلم به اطراف زمانيكه شما مي دانيد به چه چيزي نگاه مي كنيد آسان است
كه چه يك تعامل آموزشي تكه تكه شده باشد و چه هنوز در نگه دارنده آن بصورت گروهي قرار داشته باشد  شما اين نكته 

  .را چك كنيد 
  :براي بررسي اين كه آيا يك تعامل آموزشي تكه تكه شده است 
  .يك فيلد متني يا هر عنصر ديگر را در روي صحنه انتخاب كنيد 

 .بزرگ از عناصر انتخاب شده باشد ، تعامل تكه تكه نشده است اگر يك گروه  •

پس تعامل تكه تكه شده است و شما مي توانيد  اگر شما توانستيد يك فيلد متني يا عنصر ديگري را انتخاب كنيد ، •
 .براي ويرايش آن اقدام كنيد 

قادر باشيد كه پارامترهاي آن را در پانل شما بايد . ( دقت كنيد كه اجزاي تعامل آموزشي را تكه تكه نكنيد   :نكته 
Component Parameter اگر اجزاي تعامل آموزشي تكه تكه شده باشد ، دستورات .)  انتخاب كنيدScript تعامل گم خواهد 

  .اگر اين مورد اتفاق افتاد ، تعامل را حذف كنيد و آن را با يك كپي جديد آن از كتابخانه جايگزين كنيد . شد 

  اهر يك آزمونتغيير ظ
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شما . شما مي توانيد ظاهر يك آزمون را با تغيير عنوان ، رنگ زمينه و ساير ابزارها ، از قبيل فيلدهاي متني تغيير دهيد 
  . اندازه و رنگ را تغيير دهيد  مي توانيد خصوصياتي از قبيل فونت ،
  : براي تغيير عنوان يك آزمون 

  . ناميده مي شود دوبار كليك كنيد Practice Quiz در صحنه ، روي متن عنوان كه -1
  . عنوان آزمون را تايپ كنيد -2

  .تغيير دادن نحوه كار آزمون تغيير دهيد  آزمون را بدون Backgroundشما همچنين مي توانيد محتواي لايه 

  آزمايش كردن آزمون
  . ست شود آزمون ت  بارها ، زمانيكه تعاملات را اضافه و يا حذف مي كنيدبسيار مهم است 

  :براي تست كردن آزمون 
1- Control>Test Movie را انتخاب كنيد .  

  .  ظاهر مي شود  macromedia flash playerآزمون در پنجره 
  . به آزموني كه ظاهر مي شود پاسخ دهيد -2
د تا بتوانيد سند  را ببنديد و به ناحيه كاري برگرديmacromedia flash player وقتي آزمون را كامل كرديد پنجره -3

  .را ويرايش كنيد 

  Drag and Dropپيكربندي يك تعامل 
 هر عنصر . استفاده كنيد Drag and Drop و هشت عنصر مقصد در هر تعامل Dragشما مي توانيد از هشت عنصر 

Drag مي تواند به هر مقصد داراي نام در عنصر Drag and Dropعناصر .  به منظور ارزيابي بچسبدDragتوانند  مي 
شما .  مطابقت داده شوند Target8 مي توانند با Drag2 و هم Drag1 هم   براي مثال ،;مقصد هاي مشترك داشته باشند 

اين امر به شما اجازه مي دهد .  را با آن مطابقت دهيد Dragهمچنين مي توانيد يك مقصد را تعيين كنيد بدون اينكه يك عنصر 
  .ابي به آزمون اضافه كنيد كه يك گزينه نادرست براي ارزي

گزينه نادرست يك سري از .  به يك گزينه بعنوان گزينه نادرست مراجعه مي كنند  Dragهر عنصر مقصد و عنصر 
  . اين مورد براي هر انتخابي در هر تعامل آموزشي استفاده مي شود .  گزينه هاي قابل انتخاب مي باشد 
  : Drag and Dropبراي پيكربندي يك تعامل 

 را نمايش دهيد و Component Parameters تعامل آموزشي را روي صحنه قرار دهيد ، آن را تكه تكه كنيد ، پانل -1
  . تعامل و سؤال را تايپ كنيد شماره شناساييسپس 

 موجود در صحنه نمايش مي Dragها را براي عناصر  Instance name ، ليست Drag Object Nameستون  -2
  .  دهد

 كرديد جديد را به صحنه اضافه Dragاگر شما يك عنصر .  بايد يك نام منحصر بفرد داشته باشد Drag هر عنصر
  .مطمئن شويد كه نام آن را آنجا وارد كرده ايد  ،

 عناصر تطبيق داده شده براي آن عنصر هاي Instance name ، ليست Matches Target Nameدر ستون  -3
Drag نمايش داده مي شود .  

اگر شما يك مقصد جديد به صحنه اضافه كنيد ، بايد مطمئن شويد كه . مقصد بايد نام منحصر بفرد داشته باشد هر 
  .نام آن را در آنجا وارد كرده ايد 
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 وارد كنيد ، شما احتياج خواهيد داشت Drag Object Nameدر ستون  را Drag يك عنصر Instance nameاگر شما 
اگر چه شما مي توانيد يك .  وارد كنيد Matches Target Nameاظر آن را در ستون  مقصد متنInstance Nameكه 

Instance Name   مقصد در ستونMatches Target Name وارد كنيد بدون ايكه آن را با يك Instance Name عنصر  
Dragاين كار يك مقصد اضافه مي كند كه عناصر .   مطابقت دهيدDragند ولي بعنوان يك گزينه  مي توانند به آن بچسب

  . صحيح ارزيابي نمي شود 
 در صورتي كه  روي مقصد تعيين شده قرار نگرفت به محل اصلي اش Dragدر صورتي كه مي خواهيد عنصر  -4

  . تيك بزنيد Start را از جعبه Snapبرگردد گزينه 
   و عناصر مقصدDragاضافه و حذف كردن عناصر 

ش عنصر و شش مقصد را با اضافه كردن عناصر و مقصدها و يا حذف عناصر و تعداد پيشفرض ششما مي توانيد 
 و يك تا هشت عنصر مقصد در هر تعامل Dragشما مي توانيد بين يك تا هشت عنصر . مقصد هاي موجود تغيير دهيد

  .  داشته باشيد  Drag and Dropآموزشي 
  : و يا عنصر مقصد Dragبراي اضافه كردن عنصر 

اگر شما تعاملي داريد كه شش براي مثال . كليپ فيلم شامل گرافيكهايي براي عنصر مورد نظر ايجاد كنيد  يك سمبل -1
نوع ميوه دارد و شما مي خواهيد هفتمين گزينه را اضافه كنيد ، گرافيك هفتمين ميوه را ايجاد كنيد و آن را در كتابخانه قرار 

  . دهيد 
 را انتخاب كنيد و سپس سمبل را از كتابخانه به روي صحنه Drag and Drop تعامل آموزشي Timeline بر روي -2

  .درگ كنيد 
  . براي شكل وارد كنيد Instance Name يك propertyدر پانل  -3
4- Instance name را به پانل Component Parameters براي عنصر Drag and Drop اضافه كنيد .  

  .در زمان اجرا براي شما انجام خواهد داد  همه كارها ي دوباره تنظيم شده را مولفه
   :Drag and Dropبراي حذف يك عنصر 

1- Instance name عنصر Drag and Drop ي كه مي خواهيد حذف نماييد انتخاب كنيد و آن را از روي صحنه 
  . حذف كنيد 

 Componentسپس پانل را در روي صحنه انتخاب كنيد ،  ) Drag and Dropمتني در سمت چپ تعامل  ( مولفه -2

Parameters را نمايش دهيد )Window>Components. (   
3- Instance name عنصر مورد نظر را از ستون Appropriate در پانل Component Parameters حذف كنيد .  

 پيام  ثبت كنيد كه در روي صحنه موجود نيستند ، يكDrag and Drop مولفه را براي ياگر شما گزينه هاي: نكته 
  .خطاي خروجي در زمان تست كردن فيلم ظاهر خواهد شد 

  پيكربندي يك تعامل جاي خالي
يك دكمه كنترل و يك فيلد بازخورد استفاده مي  تعامل جاي خالي از يك فيلد متني سؤال ، يك فيلد متني ورودي كاربر ،

  . كند 
  :براي تنظيم يك تعامل جاي خالي 
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 را ظاهر كنيد و Component Parameters پانل  آن را تكه تكه كنيد ، قرار دهيد ، تعامل آموزشي را روي صحنه -1
  .سپس سؤال و شماره تعامل را وارد كنيد 

  . ، بين يك تا سه جواب صحيح ممكن را وارد كنيد Component Parameters در پانل -2

  
  

  :شما مي توانيد جوابهاي صحيح را به يكي از روشهاي زير تنظيم كنيد 
 وارد كنيد بطوريكه كاربر بتواند آنرا تايپ كند و بعنوان جواب صحيح در نظر Responsesقسمت  درمتني را  •

 . انتخاب كنيد Responses را در قسمت سمت راست Correctسپس گزينه . گرفته مي شود 

ايد قبول كند ، پاسخ براي تنظيم تعامل بطوريكه تمام جوابهاي ممكن را غير از جوابي كه شما آنجا تايپ كرده  •
سپس گزينه .  را در قسمت سمت راست آن از انتخاب خارج كنيد Correctغير قابل قبول را در ليست وارد كنيد و گزينه 

Correct پاسخهاي ديگر را انتخاب كنيد تا نشان دهد كه همه پاسخهاي ديگر صحيح هستند . 

 هستند كه از نظر حروف كوچك و بزرگ دقيقا مطابقت  تعيين كنيد كه آيا پاسخ هاي صحيح فقط زماني صحيح-3
با ( حروف بزرگ و كوچك صحيح هستند يا آنها بدون در نظر گرفتن  ) Case Sensitiveبا انتخاب گزينه ( داشته باشند 

   ) . Case Sensitiveانتخاب نكردن گزينه 
 را انتخاب كنيد ، يك پاسخ Exact Matchينه اگر شما گز. تعيين كنيد كه آيا تطبيق دادن پاسخ بايد دقيق باشد  -4

صحيح تنها زماني صحيح در نظر گرفته خواهد شد كه كاربر متن را دقيقا به گونه اي وارد كند كه پاسخ شما ظاهر شده است 
د  ، يك پاسخ اگر شامل كلمه درست هم باشد بعنوان پاسخ صحيح ارزيابي خواهد شExact Matchبا انتخاب نكردن گزينه . 
اين خاصيت .  وارد كند پاسخ ، صحيح در نظر گرفته خواهد شد striped zebra باشد و كاربر zebraبراي مثال ، اگر پاسخ . 

  . اگر پاسخ صحيح بيش از يك كلمه باشد كار نمي كند
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  پيكربندي يك تعامل شيء حساس
  .ش عنصر حساس استفاده مي كند نمونه پيشفرض از ش .  شيء حساس  بين يك تا هشت عنصر را مي پذيردمولفه

  :براي تنظيم يك تعامل شيء حساس 
 را نمايش دهيد و Component Parameters تعامل آموزشي را روي صحنه قرار دهيد ، آنرا تكه تكه كنيد ، پانل -1

 . را وارد كنيد Interaction IDسپس سؤال و 

 
 
ا از انتخاب خارج كنيد تا تعيين كنيد كه اگر كاربر روي آنها  را انتخاب كنيد و يCorrect براي هر عنصر ، گزينه -2

 گزينه ينشما مي توانيد چند. كليك كرد بعنوان گزينه درست در نظر گرفته شود و يا بعنوان گزينه نادرست حساب شود 
  .صحيح داشته باشيد 

  اضافه و يا حذف كردن گزينه هاي شيء حساس 
.  گزينه هاي موجود تغيير دهيد  كردننه را با اضافه كردن گزينه ها و يا حذفشما مي توانيد تعداد پيشفرض شش گزي

  .شما مي توانيد بين يك تا هشت گزينه در يك تعامل آموزشي شيء حساس داشته باشيد 
   :براي افزودن يك گزينه شيء حساس 

اگر شما تعاملي داشته  ي مثال ،برا. شامل گرافيك هايي براي گزينه شيء حساس ايجاد كنيد   يك سمبل كليپ فيلم -1
گرافيك هفتمين ميوه را ايجاد كنيد  باشيد كه شامل شش نوع ميوه است و شما مي خواهيد هفتمين گزينه را به آن اضافه كنيد ،

  .و آن را در كتابخانه قرار دهيد 
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به روي صحنه درگ كنيد سپس سمبل را از پانل كتابخانه   انتخاب كنيد ،Timeline تعامل شيء حساس را بر روي -2
.  

  . را وارد كنيد Property ، Instance name در پانل -3
4- Instance name را براي شيء حساس به پانل Component Parameters وارد كنيد .  

  .مولفه همه كارهاي تنظيم شده را در زمان اجرا دوباره از ابتدا انجام خواهد داد
  :حذف يك گزينه شيء حساس براي 

1- Instance name مربوط به كليپ فيلم شيء حساسي را كه مي خواهيد حذف كنيد انتخاب نماييد و آن را از روي 
  .صحنه حذف كنيد 

 متني را كه در قسمت سمت چپ تعامل شيء حساس در روي صحنه قرار دارد انتخاب كنيد ، سپس پانل -2
Component Parameters را نمايش دهيد )Window>Components.(   

3- Instance name مربوط به عنصر حذف شده را از ليست موجود در پانل Component Parameters حذف كنيد 
.  

اگر شما گزينه هايي را براي مولفه شيء حساس ثبت كنيد كه در روي صحنه موجود نيستند ، يك پيام خطاي : نكته 
  .خروجي در زمان تست كردن فيلم ظاهر خواهد شد 

   تعامل نقطه حساسپيكربندي يك
موجود بر  )  يا عناصر( ر آموزشي نقطه حساس تعاملي را تنظيم مي كند كه كاربر با كليك كردن روي يك عنصتعامل 
  .ه پاسخ صحيح را وارد مي كند روي صحن

  :براي پيكربندي يك تعامل نقطه حساس 
 را نمايش دهيد و Component Parameters پانل  تعامل آموزشي را روي صحنه قرار دهيد ، آن را تكه تكه كنيد ،-1

  . تعامل را وارد كنيد IDسپس سؤال و 
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 را انتخاب كنيد و يا ازانتخاب خارج كنيد تا تعيين كنيد كه اگر كاربر روي Correct براي هر ناحيه حساس ، گزينه -2

توانيد چندين پاسخ را  به عنوان پاسخ شما مي . آن عنصر كليك كرد بعنوان پاسخ درست و يا نادرست در نظر گرفته شود 
  .صحيح در نظر بگيريد 

اين گزينه شفافيت پيشفرض نقاط حساس را .  انتخاب كنيد Up State Alpha مقداري را براي گزينه  اگر لازم بود ، -3
اس بطور كاملا براي اينكه نقاط حس.  كه آن شفافيت قبل از كليك روي آن ناحيه مي باشد –بر روي صحنه تعيين مي كند 

  .واضح بر روي صحنه ديده شوند اين تنظيم را روي صفر قرار دهيد 
اين گزينه شفافيت نقاط حساس را در .  وارد كنيد Down State Alpha اگر لازم بود ، مقداري را براي گزينه -4

شما . ود در فيلم تان متفاوت باشد اين گزينه مي تواند بسته به گرافيك هاي موج. زمانيكه انتخاب شده هستند تعيين مي كند 
ممكن است بخواهيد براي دادن بازخورد ديداري به كاربر بعد از اينكه با موفقيت روي نقطه حساس كليك كرد از اين گزينه 

  .استفاده كنيد 
  گزينه هاي نقطه حساس  كردن اضافه و حذف 

 شما مي توانيد تعداد پيش . ساس داشته باشيد شما مي توانيد بين يك تا هشت گزينه در يك تعامل آموزشي نقطه ح
  .فرض شش گزينه را با اضافه كردن گزينه هاي اضافي و يا حذف گزينه هاي موجود تغيير دهيد 

 شما گزينه هاي نقطه حساس را بيش از گرافيكهاي ديگر مورد استفاده قرارخواهيد داد چرا كه كاربر واقعا  معمولا ،
گزينه هاي نقاط حساس را در طول خلق اين تصاويربصورت  نيمه شما ممكن است بخواهيد كه . د دوست دارد كه آن را ببين

اين تنظيم مي تواند .  ي هر نقطه حساس انجام دهيد Alphaشما مي توانيد اين كار را با كم كردن جلوه . نامرئي ايجاد كنيد 
  . هايي در هنگام اجرا تقويت شود Scriptبوسيله 
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  :دن يك گزينه نقطه حساس براي اضافه كر
براي مثال اگر شما تعاملي داريد كه .   يك سمبل كليپ فيلم شامل گرافيكهايي براي عنصر مورد نظر ايجاد كنيد -1

 را ايجاد كنيد و آن را در ماشين دارد و شما مي خواهيد هفتمين گزينه را اضافه كنيد ، گرافيك هفتمين ماشينشش نوع 
  .كتابخانه قرار دهيد 

 تعامل نقطه حساس را انتخاب كنيد و سپس سمبل را از پانل كتابخانه به روي صحنه درگ Timeline بر روي - -2
  .كنيد 

  . براي شكل وارد كنيد Instance Name يك property در پانل -3
4- Instance name را به پانل Component Parameters براي عنصر نقطه حساس اضافه كنيد .  

Component همه كارها ي دوباره تنظيم شده را در زمان اجرا براي شما انجام خواهد داد .  
   :براي حذف يك گزينه نقطه حساس 

1- Instance name عنصر نقطه حساسي را كه مي خواهيد حذف نماييد انتخاب كنيد و آن را از روي صحنه حذف 
  . كنيد 

 Componentصحنه قرار دارد انتخاب كنيد ، سپس پانل   متني را كه در سمت چپ تعامل نقطه حساس بر روي -2

Parameters را نمايش دهيد )Window>Components. (   
3- Instance name عنصر مورد نظر را ازليست موجود در پانل Component Parameters حذف كنيد .  

 موجود نيستند ، يك پيام خطاي اگر شما گزينه هايي را براي مولفه نقطه حساس ثبت كنيد كه در روي صحنه: نكته 
  .خروجي در زمان تست كردن فيلم ظاهر خواهد شد 

  پيكربندي يك تعامل چند گزينه اي
در يك تعامل چندگزينه اي كاربر به يك سوال با چندجواب كه يك يا چند گزينه از آن ممكن است صحيح باشد پاسخ 

  .مي دهد 
  :براي پيكربندي يك تعامل چندگزينه اي 

 را نمايش دهيد و Component Parametersامل آموزشي را روي صحنه قرار دهيد ، آنرا تكه تكه كنيد ، پانل تع -1
  .را وارد كنيد    تعاملIDسپس سؤال و 
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  .وارد كنيد  ) F تا Aاز (  پاسخ هاي ممكن را براي تعامل -2

ي از فيلدها را خالي بگذاريد ، اما مطمئن شويد شما مي توانيد بعض. نيازي نيست كه شما شش پاسخ ارائه كنيد : نكته 
  .كه فيلدهاي پاياني را خالي گذاشته ايد 

 را انتخاب كنيد و يا ازانتخاب خارج كنيد تا تعيين كنيد كه هر پاسخ درست و يا نادرست در نظر Correctگزينه  -3
   .اشته باشيدشما مي توانيد چندين پاسخ صحيح د. گرفته شود 

   كردن گزينه هاي چندگزينه اي اضافه و حذف
شما مي توانيد تعداد پيش .  شما مي توانيد بين يك تا هشت گزينه در يك تعامل آموزشي چندگزينه اي داشته باشيد 
  .فرض شش گزينه را با اضافه كردن گزينه هاي اضافي و يا حذف گزينه هاي موجود تغيير دهيد 

  :براي اضافه كردن يك گزينه چند گزينه اي 
  . انتخاب كنيد Timelineفريمي را كه شامل تعامل آموزشي چندگزينه اي است از  -1
 را CheckBoxو يك عنصر  ) Window>Library( را از پانل كتابخانه بازكنيد Flash UI Componentsپوشه  -2

  .به صحنه درگ كنيد 
  . را وارد كنيد Property ، Insatance nameدر پانل  -3
4- Instance name را براي گزينه چند گزينه اي به پانل Component Parameters وارد كنيد .  

  .كرد خواهد تنظيممولفه همه كارهاي تنظيم شده را در زمان اجرا دوباره از ابتدا 
  : چندگزينه اي عنصربراي حذف يك 
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1-Instance nameعنصر Check Boxا از روي صحنه حذف  ي را كه مي خواهيد حذف نماييد انتخاب كنيد و آن ر
  . كنيد 

 Component  متني را كه در سمت چپ تعامل چندگزينه اي بر روي صحنه قرار دارد انتخاب كنيد ، سپس پانل -2

Parameters را نمايش دهيد )Window>Components. (   
3- Instance name عنصر مورد نظر را ازليست موجود در پانل Component Parametersحذف كنيد .   

اگر شما گزينه هايي را براي مولفه جندگزينه اي ثبت كنيد كه در روي صحنه موجود نيستند ، يك پيام خطاي : نكته 
  .خروجي در زمان تست كردن فيلم ظاهر خواهد شد 

  پيكربندي يك تعامل صحيح يا غلط
  .در يك تعامل صحيح يا غلط كاربر با پاسخ صحيح يا غلط به سوال جواب مي دهد

  : پيكربندي يك تعامل صحيح يا غلط براي
 را نمايش دهيد و Component Parametersتعامل آموزشي را روي صحنه قرار دهيد ، آنرا تكه تكه كنيد ، پانل  -1

  .را وارد كنيد    تعاملIDسپس سؤال و 

  
  
  . در كادر متني سوال ، متن سوالي را كه مي خواهيد از كاربر بپرسيد وارد كنيد -2
3- Correct ، را براي تعيين اينكه كدام پاسخ True يا False شما مي توانيد .  ، پاسخ صحيح تعامل است انتخاب كنيد

  تغيير دهيد براي اين كار متن موجود در قسمت Incorrect و Correctاين پاسخ ها را اگر دوست داشته باشيد به 
Distrators در فيلد شما مي توانيد براي مثال ،.  را تغيير دهيد Distrators ، A.Correct و B. Incorrect را تايپ كنيد .  
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  درباره گزينه هاي تعامل صحيح يا غلط 
 و يك فيلد متن بازخورد ه دكمه راديويي ، يك دكمه كنترل  دو مولف تعامل صحيح يا غلط شامل يك فيلد متني سوال ،

  .هيچ گزينه ديگري براي پيكربندي وجود ندارد . مي باشد 
  تنظيم گزينه هاي بازخورد براي يك تعامل

   .گزينه هاي بازخورد كنترل مي كنند زمانيكه  كاربر پاسخي را انتخاب مي كند چه اتفاقي رخ دهد 
  :براي تنظيم گزينه هاي بازخورد براي يك تعامل 

  . دستورالعملها را براي تعامل در روي صحنه انتخاب كنيد -1
.  را انتخاب كنيد Window>Component Parameters ديده نمي شود ، Component Parametersاگر پانل  -2

  . كليك كنيد Optionsسپس روي زبانه 

  
  
 را در صورتيكه مي خواهيد فيلم ، توضيحاتي را بلافاصله بعد از آنكه كاربر پاسخ را وارد كرد Feedback گزينه -3

  .  ارائه دهد ، انتخاب كنيد 
  : را انتخاب كرديد ، موارد زير را وارد كنيد Feedback اگر گزينه -4
 . ، تعداد دفعاتي را كه كاربر فرصت دارد تا پاسخ صحيح را ارائه دهد ، وارد كنيد Triesدر قسمت  •

ظاهر شود وارد كنيد  بازخوردي را كه مي خواهيد براي كاربرقبل انجام هر كاري  ، Initial FeedBackدر قسمت  •
 زكليك كردن روي يك عنصر و درگ كردن آن به سمت عنصر تطبيقي   قبل ا  براي مثال ،–

 ، بازخوردي را كه مي خواهيد زمانيكه كاربر پاسخ صحيح داد ظاهر شود را وارد Correct Feedbackدر قسمت  •
 . بله ، اين درست است   براي مثال ،–كنيد 
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 1 آن روي triesبازخوردي را كه مي خواهيد زمانيكه كاربر پاسخ غلط داد و   ،Incorrect Feedbackدر قسمت  •
 .اين گزينه نادرست است   براي مثال ، نه ،–تنظيم بود ظاهر شود وارد كنيد 

 آن روي بيشتر از tries ، بازخوردي را كه مي خوهيد زمانيكه كاربر پاسخ غلط داد و Additional Triesدر قسمت  •
 .دوباره سعي كن  اين گزينه غلط است ،  نه ،  براي مثال ،– ظاهر شود وارد كنيد  تنظيم بود1

بنابراين براي اين نوع تعامل فيلد  كاربران در تعامل صحيح يا غلط فقط يكبار مجاز هستند كه پاسخ بدهند ، : نكته 
Additional Tries وجود ندارد  .  

 تنظيم گزينه هاي رديابي دانش براي يك تعامل
اين يك خاصيت رديابي داده .  كار مي كند LMS در SCORM و هم با قابليت AICCهم با قابليت رديابي دانش 

 مثل فضاي آموزشي LMSاتوماتيك است كه به شما اجازه مي دهد كه داده هاي مربوط به كارايي دانش آموز را به يك 
Lotus نش اطلاعات داخلي دانش آموز را بصورت يك فيلم رديابي دا.  و يا يك سيستم مدافع رديابي ديگر بفرستيد

macromedia flash  ضبط مي كند و يا ذخيره مي كند و سپس داده ها را براي يك صفحه HTML مي فرستد .  
 macromedia flash شما بايد در محتواي فيلم  براي اينكه داده ها با موفقيت براي يك سيستم رديابي فرستاده شود ،

اين صفحه زماني ايجاد مي شود .  مناسب تعبيه كنيد JavaScript شامل كدهاي HTMLزشي تان يك صفحه  در تعامل آمو
 را انتخاب كنيد Flash w/SCORM ويا رديابي Flash w/AIC  رديابي Publish Settingsكه شما فيلم را منتشر كنيد و در 

ا درخود جاسازي مي كند نياز دارد كه بخشي  رHTML ي كه فيلم AICC،   HTML از قابليت LMSبراي پشتيباني .
 استاندارد براي ارتباطات سيستم رديابي  صنعتبر اساس يكداده هاي رديابي . يمها را درخود داشته باشد رازتنظيمات ف

 اين استاندارد را تهيه 2نسخه )  صنعت هوايي CBTكميسيون  ( AICC منتقل مي شوند ،ضبط و نرم افزارهاي آموزشي 
  . بايد شامل گزينه هايي باشد است كه در اين استاندارد عناصر داده براي هر تعاملكرده 

 تنظيم Component Parametersشما مي توانيد مقادير را براي اين عناصر داده ، در يك تعامل با استفاده از پانل 
  :كنيد 

• IDتعامل  

• IDخارجي   

 وزن •

  :سبه مي شوند عبارتند از بقيه عناصر داده كه بصورت اتوماتيك تنظيم و محا
 نوع سوال •

 پاسخ صحيح •

 پاسخ كاربر •

 نتيجه •

 تاريخ و ساعت •

 زمان تاخير •

  :براي تنظيم گزينه هاي رديابي دانش براي يك تعامل 
  .دستورالعملهاي تعامل را در روي صحنه انتخاب نماييد  -1
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 را انتخاب كنيد و Window>Component Parameters ديده نمي شود ، Component Parametersاگر پانل  -2
  . كليك كنيد Optionsسپس روي زبانه 

  
از تعامل آموزشي در سندي استفاده كنيد كه با استفاده از يك الگوي آزمون ايجاد شده در صورتي كه مي خواهيد  -3

 Knowledgeنه است و شما مي خواهيد كه فيلم ، داده ها را به يك سرور بانك اطلاعاتي مديريت آموزشي بفرستد ،گزي

Track انتخاب كنيد   را.  
   . باشد انتخاب كنيد تا يك نام خارجي براي تعامل Objective ID نامي را در جعبه متن -4

 Objective تنظيم شده است مرتبط باشد ، LMSاگر تعامل با يك نام خارجي كه در . اين يك پارامتر اختياري است 

ID اگر شما كادر متني . نماييد  آن را در كادر متني مربوطه واردObjective ID عمل را خالي بگذاريد ، رديابي باز هم 
  . خواهد كرد 

الگوهاي آزمون از اين پارامتربراي محاسبه رتبه در صفحات .   را براي تعامل تعيين كنيد) وزن(Weightingمقدار  -5
  . است 1مقدار پيشفرض . نتايج استفاده مي كنند

اگر تمام تعاملات . شما مي توانيد هر مقدار عددي را در آن وارد نماييد .  سوال را نشان مي دهد وزن اهميت نسبي يك
 شمرده مي شود 4 و نصف وزن 1دوبرابر وزن  2وزن . همه آنها رتبه يكسان خواهند داشت .  داشته باشند 1آموزشي وزن 

  . بدهيد 1ك سوال مقدماتي وزن  و به ي3شما مي توانيد به يك سوال پيشرفته وزن  براي مثال ،. 
   براي يك تعاملNavigationsتنظيم گزينه هاي 

 بنابراين مطمئن شويد كه  دارند ، اسناد ايجاد شده با استفاده از الگوهاي آزمون يكسري راهنماهاي داخلي 
Navigation در اين سندي كه شما در تعامل آموزشي استفاده كرده ايد OFF باشد  .  

  :گزينه هاي راهنما براي يك تعامل براي تنظيم 
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  . دستورالعملها را براي تعامل موجود در روي صحنه انتخاب نماييد -1
سپس روي زبانه .  را انتخاب كنيد Window>Component  ديده نمي شود ،Component Parametersاگر پانل  -2

Options كليك كنيد .  

  
  

  :يلم پس از آنكه كاربر پاسخ را ارائه كرد براي تعامل چگونه عمل كند  ، تعيين كنيد كه فNavigationدر قسمت زير 
 . كليك كنيد تا راهنما را غير فعال كنيد OFFروي  •

 كليك كند ، سپس در فيلد Next كليك كنيد تا نياز باشد كه كاربر بعد از ارائه پاسخ روي دكمه Next Buttonروي  •
Go To Action،   گزينهStop  يا  Playنتخاب كنيد  را ا . 

 Go Toدر فيلد  اگر شما بخواهيد براي راهنمايي شدن از يك فريم برچسب دار به جاي فريم بعدي استفاده كنيد ،

Label  برچسب فريم را وارد كنيد .  
  .  مي باشد Next ، Next Questionمتن پيش فرض براي دكمه 

 . كليك كنيد  بعدي بعد از ارائه پاسخ توسط كاربر  براي رفتن فيلم به فريم Auto Goto Next Frame  گزينهروي •

 Auto گزينه   انتخاب شده باشد ،Knowledge Track از انتخاب خارج شده باشد و گزينه Feedbackاگر گزينه 

Goto Next Frame اين خاصيت يك رتبه بعد از ارزيابي ارائه مي دهد و بلافاصله كاربر را به فريم .  مي تواند فعال شود
  . عدي براي تعامل بعدي هدايت مي كند ب

 Auto Goto گزينه   از انتخاب خارج شده باشد ،Knowledge انتخاب شده باشد و گزينه Feedbackاگر گزينه : نكته 

Next Frame دوباره روي Next Button تنظيم خواهد شد و يك پيام خطا در پنجره خروجي ظاهر خواهد شد .  
  و ثبت كردن ابزارهانام گذاري  اضافه كردن ،
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  :  شامل ابزارهاي زير است Macromedia Flash MXهر يك از تعاملات آموزشي 
 يك مولفه تعامل •

 فيلدهاي متني پويا •

 عناصر گزينه ها •

 )UI(مولفه كليد فشاري رابط كاربر  •

اين كليپهاي فيلم . مجموعه ابزارها براي هر نوع تعامل در داخل سمبل هاي كليپ فيلم در كتابخانه ذخيره مي شود 
براي اجتناب از قابل حمل بودن ابزارها در نظر گرفته شده است بنابراين آنها مي توانند به فريم هاي كليدي در داخل يك فايل 

  .آنها فقط درنظر گرفته شده اند تا بعنوان محفظه استفاده شوند و لازم نيست كه براي تعامل كار كنند . كپي شوند 
 هاي Instance Nameدهنده آزمون هستيد با دستكاري آزمون و نامگذاري گرافيكها مي توانيد اگر شما يك توسعه 

شما نياز نداريد كه از محفظه هاي كليپ فيلم و يا از الگوها به جاي  . خودتان را براي ابزارهاي گرافيكي در صحنه وارد كنيد
ضافه كنيد ، سپس يك مولفه تعامل آموزشي به صحنه اضافه شما ممكن است كه ابزارهايتان را به صحنه ا. آن استفاده كنيد

  .  براي تعامل ثبت نماييد Component Parameters هاي ابزارها را در پانل Instance Nameكنيد  و بعد 
  :موارد زير را در مورد نامگذاري ابزارها به خاطر بسپاريد 

 .مولفه هاي آموزشي نياز به نامگذاري ندارند  •

 . نياز دارند كه يك نام منحصربه فرد براي انواع تعاملات مشابه داشته باشند UIمولفه هاي  •

 بايد يك نام منحصر به فرد  )نقاط حساس و عناصر حساس  عناصر مقصد ،  ،Dragعناصر ( هر گزينه گرافيكي  •
 .داشته باشند 

 .فاده نمايند فيلدهاي متني مي توانند از نامهاي مشابه بصورت اشتراكي در چندين تعامل است •

 براي Component Parametersمهم اين است كه آن نامها در پانل  ابزارها در روي صحنه يكبار نامگذاري مي شوند ،
  .تعامل آموزشي ثبت شوند ، بطوريكه اسكريپت ها بتوانند ابزارها را كنترل نمايند 

  نامگذاري مولفه هاي تعامل آموزشي
اين مولفه .  پارامترهاي آن را بصورت منحصربفرد  پيكربندي مي كند  ،دارد كه با آنهر تعاملي يك مولفه تعامل واحد 

  .ها نيازي به نامگذاري ندارند 
  ) ها و دكمه هاي فشاريCheckBox دكمه هاي راديويي ، ( UIنامگذاري مولفه هاي 

 نام منحصربفردي بدهيد UIهر مولفه  نياز خواهيد داشت كه به  از انواع تعاملات مشابهي استفاده مي كنيد ،وقتي شما 
 هاي Instance Nameاگر شما دو تعامل چند گزينه اي ايجاد كنيد ، تعامل دوم نياز خواهد داشت كه ازبراي مثال ، . 

 هاي جديد نيازدارند كه Instance Name اين . و كليدهاي فشاري استفاده كند Check Boxمنحصربفردي براي مولفه هاي 
  .اي مولفه تعامل ثبت شوند با پارامتره

   : UIبراي نامگذاري يك مولفه 
  . را در روي صحنه انتخاب كنيد UI نام مولفه -1
 تايپ كنيد Instance Name كليك كنيد و سپس يك نام در جعبه متن Parametersروي زبانه   ،Propertyدر پانل  -2

.  
  .نام را ثبت كنيد  -3
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  نامگذاري فيلدهاي متن پويا
اگر شما دو تعامل   براي مثال ،–ما بيش از يك عدد از هر نوع از تعاملات آموزشي در يك آزمون داريد اگر ش

 Instanceاين .  عناصر هر تعامل آموزشي بايد نامهاي منحصربفرد داشته باشند – داريد Drag And Dropآموزشي 

Nameد  هاي منحصربفرد جديد بايد با پارامترهاي مولفه تعامل ثبت شون.  
  : براي نامگذاري يك فيلد متن پويا 

  . فيلد متن پويا را در روي صحنه انتخاب كنيد -1
 وارد كنيد Instance Name  كليك كنيد ، سپس يك نام در جعبه متن Parameters ، روي زبانه Property در پانل -2

.  
                                                                                                     Instance Name 

  

  
  

  ) .نه نام متغير را(  وارد كرده ايد Property را در پانل Instance Nameمطمئن شويد كه  :نكته 
  . نامها را ثبت كنيد -3

  :براي ثبت فيلدهاي متن پويا و مولفه هاي دكمه فشاري 
 را Component Parametersر روي صحنه انتخاب نماييد و پانل متن را در قسمت سمت چپ تعامل آموزشي ب -1

   ) .Window>Components( نمايش دهيد 
  . كليك كنيد Assets روي دكمه -2
  . نام را در جعبه متن مناسب وارد نماييد  -3
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  نام دادن و ثبت گزينه هاي گرافيكي
اس و عناصر حساس نياز دارند كه نام منصر  ، عناصر مقصد ، نقاط حسDragگزينه هاي گرافيكي مثل عناصر 

 كه هر كدام Drag And Dropاين به اين معناست كه در يك فايل با دو تعامل . بفردي در بين كليه تعاملات داشته باشند 
براي مثال عناصر .  بايد نامهاي منحصربفردي داشته باشند Drag مي باشند همه هشت عنصر Dragشامل چهار عنصر 

Drag     در اولين تعامل مي توانند بصورتDrag 4 , Drag 3 , Drag 2 , Drag 1 نامگذاري شوند و عناصر Drag  در 
اين كار تضمين مي كند كه .  نامگذاري شوند Drag D , Drag C , Drag B , Drag Aدومين تعامل مي توانند بصورت 

Scriptظر گرفته شده است رفتار كنند  ها به درستي كار كنند و تعاملات بطوريكه برايشان در ن.   
  :براي نامگذاري گزينه هاي گرافيكي 

  .مطمئن شويد كه عناصر موجود در صحنه مربوط به تعاملات آموزشي و يا سمبلهاي كليپ فيلم هستند  -1
  . براي مثال يك عنصر مقصد –يك عنصر را در صحنه انتخاب كنيد  -2
 در جعبه متن مربوطه وارد Instance Name كليك كنيد و سپس يك Parameters ، روي زبانه propertyدر پانل  -3

  .نماييد 
  . را براي هر عنصر در صحنه انتخاب نماييد 3 تا 1 مراحل -4
  . نامها را ثبت كنيد -5

  Drag 3, Drag 2, Drag1  براي مثال –يك طرح نامگذاري ترتيبي معمولا كار كردن را ساده تر مي كند : نكته 
  :  يك گزينه Instance Nameت براي ثب
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 Component و پانل  )متني در گوشه سمت چپ تعامل آموزشي مي باشد (  مولفه را در صحنه انتخاب كنيد -1

Parameters را نمايش دهيد )Window>Components . (   
  . وارد كنيد نام راInstance Name درجعبه متن Interaction در زبانه Component Parameters در پانل -2
  

  
  

  نامهاي فيلدهاي متني
به اين معني كه فيلد متني . فيلدهاي متني مي توانند از نامهاي اشتراكي در يك تعامل با تعامل ديگر استفاده نمايند 

ه با اين نامها نياز دارند ك.  نامگذاري شود و به همين ترتيب 2 مي توانند مانند فيلد متني سوال در تعامل 1سوال در تعامل 
  .طوري ثبت شوند كه همه نامهاي ابزارها را شامل شوند  مولفه هاي تعامل 

  نامهاي پيشفرض براي ابزارها
بصورت  در جدول زير ليست شده اند موجود  هايInstance Name باملات كليپ فيلم با قابهايي كه ابزارها در تعا

  . نامگذاري مي شوند پيش فرض 
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  Drag And Dropشي نامهاي ابزارهاي تعامل آموز
  

 Instance Name  نوع عنصر  توصيف  ابزار

 Template_Question  فيلد متني پويا  متن سوال را نگه مي دارد  فيلد متني سوال

  Template_Feedback  فيلد متني پويا  متن بازخورد را نگه مي دارد  فيلد متني بازخورد
پاسخ را به كاربر ارائه ميدهد   دكمه كنترل

   را كنترل ميكندو راهنماها
  Template_ControlButton  مولفه دكمه فشاري

  Template_ResetButton  مولفه دكمه فشاري   را دوباره تنظيم ميكندDragعناصر   Resetدكمه 
 عنصر 8 تا 1بين 

Drag 
  Drag8  تا  Drag1  سمبل كليپ فيلم Dragگزينه هاي عنصر 

 عنصر 8 تا 1بين 
  مقصد

  Target8   تا   Target1  سمبل كليپ فيلم Dragمقصد براي عناصر 

 

  نامهاي ابزارهاي تعامل آموزشي جاي خالي
  

 Instance Name  نوع عنصر  توصيف  ابزار

 Template_Question  فيلد متني پويا  متن سوال را نگه مي دارد  فيلد متني سوال

  Template_Feedback  فيلد متني پويا  متن بازخورد را نگه مي دارد  فيلد متني بازخورد
كاربر پاسخ خود را در اين   فيلد ورودي كاربر

  فيلد متني تايپ مي كند
  Template_UserEntry  فيلد متن ورودي

پاسخ را به كاربر ارائه ميدهد   دكمه كنترل
  و راهنماها را كنترل ميكند

  Template_ControlButton  مولفه دكمه فشاري

  
  نامهاي ابزارهاي تعامل آموزشي عنصر حساس

  
 Instance Name  نوع عنصر  توصيف  ابزار

 Template_Question  فيلد متني پويا  متن سوال را نگه مي دارد  فيلد متني سوال

  Template_Feedback  فيلد متني پويا  متن بازخورد را نگه مي دارد  فيلد متني بازخورد
پاسخ را به كاربر ارائه ميدهد   دكمه كنترل

  و راهنماها را كنترل ميكند
  Template_ControlButton  مولفه دكمه فشاري

عناصر حساس را دوباره   Resetدكمه 
  تنظيم مي كند

  Template_ResetButton  مولفه دكمه فشاري

 8  تا  HotObject1  سمبل كليپ فيلم گزينه هاي عنصر حساس  عنصر حساس8 تا 1بين 
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   حساسنقطهنامهاي ابزارهاي تعامل آموزشي 

  
 Instance Name  نوع عنصر  توصيف  ابزار

 Template_Question  فيلد متني پويا  متن سوال را نگه مي دارد  فيلد متني سوال

متن بازخورد را نگه   فيلد متني بازخورد
  مي دارد

  Template_Feedback  فيلد متني پويا

پاسخ را به كاربر ارائه ميدهد   دكمه كنترل
  و راهنماها را كنترل ميكند

  Template_ControlButton  ريمولفه دكمه فشا

نقاط حساس را دوباره تنظيم   Resetدكمه 
  مي كند

  Template_ResetButton  مولفه دكمه فشاري

 نقطه 8 تا 1بين 
 حساس

 8  تا  HotSpots1  سمبل كليپ فيلم گزينه هاي نقطه حساس

 

  نامهاي ابزارهاي تعامل آموزشي چند گزينه اي 
  

 Instance Name  نوع عنصر  توصيف  ابزار

 Template_Question  فيلد متني پويا  متن سوال را نگه مي دارد  فيلد متني سوال

  Template_Feedback  فيلد متني پويا  متن بازخورد را نگه مي دارد  فيلد متني بازخورد
پاسخ را به كاربر ارائه ميدهد   دكمه كنترل

  و راهنماها را كنترل ميكند
  Template_ControlButton  مولفه دكمه فشاري 

   8 تا 3بين 
Check Box 

  8  تا  Check Box Checkbox1مولفه  Check Boxگزينه هاي 

  
  نامهاي ابزارهاي تعامل آموزشي صحيح يا غلط

  
 Instance Name  نوع عنصر  توصيف  ابزار

 Template_Question  فيلد متني پويا  متن سوال را نگه مي دارد  فيلد متني سوال

  Template_Feedback  فيلد متني پويا  متن بازخورد را نگه مي دارد  ردفيلد متني بازخو
پاسخ را به كاربر ارائه ميدهد   دكمه كنترل

  و راهنماها را كنترل ميكند
  Template_ControlButton  مولفه دكمه فشاري

دكمه هاي راديويي گزينه هاي   عدد دكمه راديويي
True و False 

 ,Template_Radio1  مولفه دكمه راديويي
Template_Radio2 

  
    

  تغيير طراحي يك تعامل آموزشي
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شما ممكن است بخواهيد طراحي ظاهر يك تعامل آموزشي را تغيير دهيد تا خواسته هاي شما را برآورده كند ، 
براي مثال ، . و عنصر حساس   و نقطه حساس Drag And Drop مثل تعاملهاي  مخصوصا اگر تعامل گرافيكي تر باشد ،

 نياز از قبل در نظر گرفته شده است و بايد با گرافيكهاي مورد Drag And Dropگرافيكهاي پيشفرض براي يك تعامل 
  .تعويض شود 

  :تغيير طراحي گرافيك چهار روش دارد 
 مديريت ابزارها •

 ايجاد كردن كپي هايي از تعاملات در پانل كتابخانه •

 تغيير دادن گرافيكها •

  macromedia flashشخصي سازي مولفه هاي  •

  مديريت ابزارها
 سمبلها به  وقتي شما يك تعامل آموزشي را از كتابخانه عمومي تعاملات آموزشي به روي صحنه درگ مي كنيد ،

 macromedia flashوسيله همان تعامل آموزشي مورد استفاده قرار مي گيرند وآنها را از كتابخانه عمومي به كتابخانه سند 

 را از كتابخانه عمومي Drag And Drop اگر شما يك تعامل آموزشي براي مثال ،. كرده ايد كپي مي كند   ي كه شما ايجاد 
در مجموع براي هر سمبلي كه از (  سمبلهاي زير به كتابخانه سندتان اضافه مي شود  تعاملات آموزشي به سندتان كپي كنيد ،

  ) . قبل به سند اضافه شده است 
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آنها از كتابخانه عمومي به سند . لهاي موجود در كتابخانه عمومي تعاملات آموزشي ارتباط دارند اين سمبلها با سمب
  . تاثيري نميگذارد) ابخانه عمومي در كت( كپي مي شوند و اگر تغييري در آن بوجود آوريد روي سمبلهاي اصلي 

در كتابخانه عمومي . املات آموزشي نيستند سمبلها در كتابخانه سند به ترتيب سمبلها در كتابخانه عمومي تعاگرچه ، 
 در حالت  براي مثال ،.  سمبلها به وسيله سند تعامل آموزشي اصلي در پوشه ابزارها مرتب مي شوند  تعاملات آموزشي ،

 و يك پوشه ابزارهاي Drag And Drop كتابخانه عمومي تعاملات آموزشي شامل يك مولفه   ،Drag And Dropتعامل 
Drag And Drop است .  
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اگر .  شما مي توانيد آنها را در يك زير پوشه در پانل كتابخانه مرتب نماييد  براي مديريت بهتر سمبلها در سندتان ،
شما از تعاملات زيادي استفاده مي كنيد يا اگر شما از انواع مشابه اين تعامل بيش از يك بار در آينده با تغيير طراحي 

  .كار خوبي خواهد بود  د كرد اين كار ،گرافيكي آن استفاده خواهي
  :براي انتقال سمبلهاي تعامل آموزشي به يك پوشه در كتابخانه 

  . را انتخاب كنيد Window>Library اگر كتابخانه براي سند ديده نمي شود -1
  :  در قسمت سمت چپ پانل كتابخانه كليك كنيد New Folder روي آيكن -2

  . پانل كتابخانه ظاهر مي شود  درuntitledيك پوشه با نام 
   . Hot spot 1 يا Drag And Dropمثل  يك نام براي پوشه جديد وارد كنيد ، -3

 و يا با كاربرد آن در سند ارتباط Multiple Choice مثل  نام شما بهتر است كه با نوع تعامل رابطه داشته باشد ،
   .Question 5داشته باشد مثل 

  .سمبلها را براي تعامل آموزشي اي كه با آن كار مي كنيد به پوشه جديد درگ كنيد  در پانل كتابخانه ، -4
 در Command – Clickيا  ( Ctrl – Click و يا Shift-Clickبراي انتخاب چند گزينه در پانل كتابخانه روي آنها 

  . كنيد ) مكينتاش 
  . ب نشده اندمطمئن شويد كه ابزارهايي كه به تعامل آموزشي تعلق ندارند انتخا

  ايجاد كپي هايي از تعاملات در كتابخانه
موجود در سند تغيير مي اصلي هنگامي كه شما ظاهر گرافيكي يك سمبل را در كتابخانه تغيير مي دهيد ، همه سمبلهاي 

  .كند 
 macromediaبراي اين منظور ، اگر شما مي خواهيد از نوع خاصي از تعامل آموزشي بيش از يك بار در يك سند 

flash  يا (  استفاده كنيد و شما مي خواهيد كه از طراحي هاي گرافيكي مختلفي براي هر كپي تعامل آموزشي استفاده كنيد
  . ، شما نياز داريد كه براي هر كپي تعامل يك كپي از سمبل در كتابخانه ايجاد نماييد )  اصل آن 

ه مولفه عنصر حساس موجود در كتابخانه عمومي تعاملات براي مثال ، اگر آزمون شما دو تعامل عنصر حساس بر پاي
آموزشي دارد و آنها گرافيكهاي متفاوتي را استفاده مي كنند شما نياز داريد كه دو كپي از سمبل عنصر حساس در كتابخانه 

  .داشته باشيد 
  :براي ايجاد كپي از تعامل آموزشي موجود در پانل كتابخانه 

ا انجام نداده ايد ، اولين كپي از تعامل را از كتابخانه عمومي تعاملات آموزشي به روي  اگر شما قبلا اين كار ر-1
  .صحنه درگ كنيد و سمبلهاي وابسته را به يك پوشه در پانل كتابخانه انتقال دهيد 

  . در پانل كتابخانه سند ، سمبلهاي كپي شده را تغيير نام دهيد -2
  :ر حساس ، كتابخانه سند شامل اين سمبلها خواهد بود براي مثال ، در حالت تعامل آموزشي عنص
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• Hot_Object1 
• Hot_Object2 
• Hot_Object3 
• Hot_Object4 
• Hot_Object5 
• Hot_Object6  

  :شما ممكن است براي تغيير نام اين سمبلها از نامهاي زير استفاده كنيد 
• 01_HotObject 
• 02_HotObject 
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• 03_HotObject 
• 04_HotObject 
• 05_HotObject 
• 06_HotObject  
  .يك كپي جديد از تعامل آموزشي را از كتابخانه عمومي تعاملات آموزشي به سند درگ كنيد -3

  .اكنون شما مي توانيد گرافيكها را در هر كپي تعامل آموزشي بدون تاثير روي ظاهر ساير كپي ها تنظيم كنيد 

  تغيير ظاهر يك تعامل آموزشي
 شما مي توانيد ابزارهاي آن را جابه جا كرده و  مي شود و تكه تكه مي شود ،يك تعامل آموزشي به صحنه اضافه 

براي مثال ، شما مي توانيد فيلد متني را آنقدرتوسعه دهيد تا با خطوط بيشتر متن تطبيق پيدا كند و شما . تغيير اندازه دهيد 
به خوبي عناصر گرافيكي را به تعامل وانيد شما مي ت. مي توانيد فونت ، اندازه ، رنگ و ساير مشخصات را تنظيم كنيد 

  .آموزشي تان اضافه كنيد 
  تغيير گرافيكها در يك تعامل آموزشي

 ، نقطه حساس و عنصر حساس ، شما مي توانيد ظاهر گزينه هاي گرافيكي Drag And Dropبراي تعاملات آموزشي 
به ياد داشته باشيد كه هر وقت كه شما ظاهر . دهيد را براي به دست آوردن اهداف آموزشي مورد نظرتان در تعامل تغيير 

  . يك عنصر گرافيكي موجود در كتابخانه را تغيير مي دهيد ظاهر آن در سند تغيير مي كند 
 ايجاد شده است UIگرافيكها براي دكمه هاي راهنما و براي تعاملات صحيح يا غلط و چند گزينه اي توسط مولفه هاي 

 براي كسب .كها فقط زماني توصيه مي شود كه براي كاربران سطح مياني و پيشرفته استفاده شود تغيير دادن اين گرافي. 
شما مي توانيد اين گرافيك ها .  مراجعه نماييد FlashMXHelp>Using Flash>Using Componentsاطلاعات بيشتر به 

  .را تغيير اندازه دهيد و يا ظاهر آنها را اندكي تغيير دهيد 
  : ، نقطه حساس و عنصر حساس Drag And Dropر ظاهر عنصر براي تغييي

  . ، فريم كليدي را كه حاوي كليپ فيلم است انتخاب كنيد Timeline در -1
  .در روي صحنه ، روي قسمتي از تعامل آموزشي كه مي خواهيد ويرايش كنيد دابل كليك كنيد  -2

Macromedia flash  عنوان را در پايين Timeline مي كند تا نشان دهد كه شما كدام سمبل را ويرايش مي  به روز
  .كنيد 

  
  
 براي ويرايش سمبل در روي صحنه استفاده كنيد تا به گونه اي كه  macromedia flash از ابزارها و دستورات -3

  . مي خواهيد در سندتان ظاهر شود 
  . انتخاب كنيد  راEdit>Edit Document زمانيكه ويرايش سمبل را تمام كرديد گزينه -4
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   ها و دكمه هاي راديوييCheckboxتغيير دكمه هاي فشاري ، 
 UI (macromedia flash( و دكمه راديويي رابط كاربرCheck boxتعاملات آموزشي از مولفه هاي دكمه فشاري ، 

MX   شما بايد از اين مولفه هاي .  استفاده مي كنندUI با الگوهاي تعامل آموزشي استفاده كنيد  .Script هاي تعامل 
  . استفاده مي كنند تا هر كاري را به درستي انجام دهند UIآموزشي از خصوصيات داخلي مولفه هاي 

  . براي هر تعاملي هستند UIالگوهاي آزمون از قبل شامل همه مولفه هاي 
  تغيير اندازه
تا بتوانند به اندازه مورد نظر شوند  استفاده مي Resetمولفه هاي دكمه فشاري براي دكمه هاي كنترل و دكمه هاي 

 ;دكمه راديويي از ارتفاع نمي توانند تغيير اندازه داده شوند   و Check boxندازه دهند ، گرافيك هاي مولفه ها ي  اشما تغيير
  .اگرچه ، شما مي توانيد اين مولفه ها را افقي تغيير اندازه دهيد تا ناحيه افقي قابل ديد متن توسعه يابد 

  UIيير گرافيكهاي مولفه هاي تغ
 Macromediaبراي اطلاعات بيشتر به . يكسري مراحل از پيش تعريف شده براي تغيير پوسته يك مولفه وجود دارد

Flash MX Help>Using Flash>Using Component مراجعه نماييد .  
  UIتنظيم متن مولفه 

جزئيات اين .  استفاده كنيد UIصوصيات متن مولفه  براي تغيير خGlobal Style Sheetشما مي توانيد از عنصر 
   ) .Help>Using Flash>Using Component( آمده است macromedia flash MX online Helpمطلب در 

  استفاده از مولفه ها در الگوهاي تعامل آموزشي
 درست را به مجموعه UI هاي شما به سادگي مي توانيد مولفهبراي استفاده از مولفه ها با الگوهاي تعامل آموزشي ، 

 مولفه هاي تعامل را بصورت وابسته Instance Nameشما سپس بايد . ابزارهاي تعامل اضافه كنيد و نام آنها را عوض كنيد 
  .  مناسبي است كه نامگذاري شده هستند UIهر الگوي تعامل از قبل شامل مولفه هاي . به تعامل ثبت كنيد 

 ( Macromedia Flash MX online help مي توانيد به UIي مولفه هاي براي كامل كردن مستند ساز
Help>UsingFlash>Using Components (  مراجعه نماييد .  

 هاي تعامل آموزشي ، پارامترهاي مولفه Script. پارامترهايي دارند كه به آنها وابسته هستند  ، UIمولفه هاي   :نكته 
UI هيچ نيازي نيست كه پارامترهاي منحصربفرد خارجي را براي دكمه هاي فشاري ، .  را در زمان اجرا لغو مي كندCheck 

Box ها و يا دكمه هاي راديويي پر كنيد  .  

  SCORM يا AICC مورد توافق (LMS) رديابي سيستم مديريت آموزشي
 SCROM يا AICC مورد توافق LMS و الگوهاي آزمون به سادگي اجازه مي دهند تا با Flashتعاملات آموزشي 

 بصورت داده هايي با قالب  را پاسخ HTML/Java Script و فايلهاي ه ساخته شدFlashسند   دركد. ارتباط برقرار كنيد 
 امتياز و زمان مصرف شده كلي را رديابي كنند فقط  ،تعاملات  تا زمانيكه الگوهاي آزمون. فرستد مي  LMSمناسب براي 

  .  فرستند داده هاي مربوط به سوال را مي
، تفاوتهايي در قبول فايلهاي ايجاد شده با تعاملات  ) SCORM و AICC( به دليل تفاوتهاي بين دو استاندارد رديابي 

  .  و الگوهاي آزمون وجود دارد Flash MXآموزشي 
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ديگري  ، محتوي بايد يك دستور اصلي را در زمان شروع و يا قبل از فرستادن هر دستوررديابي SCORMدر توافق 
.  يك تعامل به تنهايي نمي تواند اين كار را انجام دهد ;فقط الگوهاي آزمون يك دستور اصلي مي فرستند .  صدا بزندLMSبه 

 با قابليت AICCبه يك   Flashبنابراين تعاملات ممكن است بدون الگوي آزمون كار نكنند ، مگر اينكه تعاملات در محتواي 
LMS ه تنهايي نمي توانند امتياز كلي و داده هاي رديابي را بفرستند ، اما آنها مي توانند داده هاي تعاملات ب.  اضافه شوند

  . سوال و يا تعامل را بفرستند 
 به LMS مطابقت كنند تا داده ها از SCORM يا AICCدر مجموع ، آزمون ها ايجاد مي شوند تا با استانداردهاي 

  . فراخوانده نشوند Flashفايل 

  SCORM و AICCر ارتباط براي محتواي توافق مروري ب
در زير بصورت خلاصه مروري بر آزمونهاي دانش آموزان خواهيم داشت ، در زمانيكه يك آزمون كامل ميشود و 

  . طي يكسري مراحل مخفي بدون اينكه دانش آموز متوجه شود اطلاعات فرستاده مي شود
  AICCمروري بر ارتباط 

1- LMSند  شروع به كار مي ك.  
  . ثبت مي شود LMS دانش آموز در -2
در اين . راهنمايي مي شود  )AU( دانش آموز از ميان ساختارهاي دوره آموزشي براي يافتن يك واحد معين  -3

  . ايجاد شده است Flash MX است ، كه با استفاده از يك الگوي آزمون Flashحالت ، فرض مي كنيم كه آن يك آزمون 
  .را آغاز مي كند ) آزمون  ( Flashاي  دانش آموز محتو-4
براي رديابي  . htm.flashcontent/myserver://httpبراي مثال ، . محتوي روي يك وب سرور قرار مي گيرد  -5

  .  جاسازي شود Flash/AICCمناسب ، فايل فلش احتياج دارد كه در فريم ست رديابي 
  .اين مورد در معرض ديد كاربر نيست : نكته 

6- LMS به آخر آدرس هاي  دو پارامتر ايجاد مي كند كهAICC_URL و AICC_SID پيوست مي شود  .URL 
  :پاياني زمانيكه محتوي آغاز مي شود مشابه زير ديده مي شود 

http://myserver/flashcontent.htm?AICC_URL=http://mylmsserver/trackingurl.asp&AICC_SID=1
2345 

  .اين مورد در معرض ديد كاربر نيست  :نكته 
  .دانش آموز در آزمون به سمت جلو حركت مي كند  -7
داده هاي .  مي فرستد LMS به HTML/JavaScript ميان فايلهاي رديابي فيلم فلش داده هاي رديابي را از -8

 . رديابي زمانيكه دانش آموز به يك سؤال پاسخ مي دهد و به صفحه بعدي مي رود فرستاده مي شوند 

  .اين مورد در معرض ديد كاربر نيست : نكته 
  SCORMمروري بر ارتباط 

  : گرفته مي شود ، وقايع زير رخ مي دهد SCORMوقتي از يك دانش آموز يك آزمون مطابق با 
1- LMS آغاز مي شود .  
  . ثبت مي شود LMS نام دانش آموز در -2
  . را آغاز مي كند  macromedia flash دانش آموز يك آزمون ساخته شده با الگوي آزمون – 3
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 SCORMمطابق با بطوريكه در يك فريم ست  جاسازي مي شود ، Flash/SCORM HTMLمحتوي در الگوي  -4
  .آغاز مي شود 

  .اين مورد در معرض ديد كاربر نيست : نكته 
LMS مسئول ايجاد فريم ست مطابق با ، SCORM مي باشد ، كه شامل همه توابع مورد نياز براي ارتباط با LMS 

  . مي باشد 
  . دانش آموز در آزمون به سمت جلو حركت مي كند -5
  . مي فرستد LMS به HTML/JavaScript از ميان فايل هاي رديابي  فايل فلش داده هاي رديابي را-6

  آماده سازي فيلمها براي ميزباني وب
 آن را در يك بايد شما را ببينند ، شما  macromedia flashدر مجموع براي اينكه كاربران وب قادر باشند كه فيلم 

  .صفحه وب جاسازي كنيد 
  . براي ميزباني وب اندكي متفاوت است SCORM و AICCمراحل آماده كردن فايلهاي مطابق با 

  AICCآماده سازي فايلهاي مطابق با 
رديابي را براي آزمون فعال كنيد  ، شما نياز داريد كه AICC با قابليت LMSبراي فرستادن داده هاي رديابي ، به يك 

 توليد شده SWF و HTML بايد فايلهاي شما.  منتشر كنيد Flash w/AICCو سپس فيلم را با استفاده از الگوي رديابي 
نام آزمونتان  را در سرور وبتان در يك پوشه مشابه قرار دهيد و نام فايل فريم ست را به  macromedia flashتوسط 

 تان بايد مطابق با LMSدر مجموع ،  .  روي وب سرور قرار دهيد SWF و  HTMLتغيير دهيد ، سپس آنرا با فايلهاي 
AICC به صورت پيشفرض ، اين فايل . ه فريم ست مراجعه كند ب باشد وFrameset.html ناميده مي شود .  

  : براي ميزباني وب AICCبراي آماده سازي يك فايل مطابق با 
  .  باز كنيد Flash MX سند را در -1
2- File>Publish Settings را انتخاب كنيد .  
 Formats در پانل HTML و Flash(.swf)كه هر دو گزينه مطمئن شويد  Publish Settings در جعبه پيغام -3

  . انتخاب شده باشد 
 Flash w/AICC Tracking كليك كنيد و گزينه Publish Settings در بالاي جعبه پيغام HTML روي زبانه -4

template را انتخاب كنيد .  
  .ك كنيد و جعبه پيغام را ببنديد ي كلPublish روي دكمه -5
استفاده از انتشار فايل فلش روي سرور وب را در يك پوشه مشابه  توليد شده با HTML فلش و فايل SWF فايل  -6

  .قرار دهيد 
 قرار بگيريد و سپس Flash MX را باز كنيد ، اول در پوشه برنامه srvrزير پوشه فايلهاي با پسوندهاي آموزشي  -7

 و frameset.htm, results.htm( محتواي اين پوشه را   . دقرار بگيري Run\HTML\Learning Extensionsزيرپوشه در 
  . منتشر شده در فلش به پوشه مشابه  در سرور وب كپي كنيد HTML و فايل SWFمشابه فايل )  ها Scriptپوشه 

  . را در يك ويرايشگر متني باز كنيد Frameset.htmlكپي جديد فايل  -8
  :شود  پيدا مي frameset.htmlخطوط زير در فايل 

<frameset frameborder="0" border="0" framespacing="0" rows="*,1"> 
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<frame src="Untitled-1.htm" name="content" frameborder="0"> 
<frame src="results.htm" name="cmiresults" scrolling="0" frameborder="0">  

  . منشر كرده ايد تغيير دهيد Flash ي كه در HTML را به نام فايل Untitled-1.htm  در خط دوم ، -9
تا به فايل )  را ايجاد كنيد AICCيا فايلهاي توصيف كننده برنامه آموزشي (  را اجرا كنيد LMSسيستم  – 10

frameset.html رجوع كند .  
  SCORMآماده سازي يك فيلم مطابق با 

شما بايد رديابي را براي آزمون فعال كنيد و فيلم  ، SCORM مطابق با LMSبراي فرستادن داده هاي رديابي به يك 
 توليد شده SWF و HTMLدر مجموع ، شما بايد فايلهاي .  منتشر كنيد Flash w/SCORMرا با استفاده از الگوي رديابي 

  .  را در سرور وبتان در يك پوشه مشابه قرار دهيد  macromedia flashتوسط 
  : براي ميزباني وب SCORMبراي ايجاد يك فيلم مطابق با 

  . باز كنيد Flash MX سند را در -1
2- File>Publish Settings را باز كنيد .  
 انتخاب شده Formats در پانل HTML و هم Flash (.swf) مطمئن شويد كه هم Publish Settingsدر پنجره  -3

  .است 
 Flash w/AICC Trackingد و گزينه  كليك كنيPublish Settings در بالاي جعبه پيغام HTMLروي زبانه  -4

template را انتخاب كنيد .  
  . كليك كنيد و جعبه پيغام را ببنديد Publish روي دكمه -5
 توليد شده با استفاده از انتشار فايل فلش روي سرور وب را در يك پوشه مشابه HTML فلش و فايل SWFفايل   -6

  .قرار دهيد 
 براي اجرا كردن فريم ست LMSمطمئن شويد كه .  رجوع كنيد HTML نام فايل  را اجرا كنيد و بهLMSسيستم  -7
  . تنظيم شده است SCORMرديابي 

   هاي تعامل آموزشي Scriptتوسعه 
اين بخش براي مداخله و توسعه پيشرفته براي اشخاصي كه مي خواهند قابليتهاي تعامل را توسعه اطلاعات در : نكته 

  .ت دهند در نظر گرفته شده اس
 از ساختارهاي سازماندهي داده زيادي براي ذخيره و بازيابي اطلاعات  macromedia flashتعاملات آموزشي 

اين مورد ارزيابي را قدرتمند مي كند و امكانات جديدي را براي توسعه دهندگاني . درباره هر بخش از تعامل استفاده مي كنند 
  .  ناميده مي شود SessionArrayاين ساختار داده . ايجاد مي كندبي را توسعه دهندكه مي خواهند خصوصيات رديا

از اين كلمات به .  سطوحي از موقعيت تعامل هستند دررزرو شده  كلمات كليدي Session و Session Array: نكته 
  .عنوان شناسه ها براي داده هاي ديگر استفاده نكنيد 

  Session Arrayدستيابي به داده هاي رديابي تجمعي از ميان 
  . آورده شده است Session Arrayدر زير خلاصه اي از چگونگي رديابي داده ها از ميان 

وقتي فيلم فلش آغاز مي شود ، مولفه تعامل اول براي بارشدن يك آرايه جديد را در سطح ابزارهاي تعامل ايجاد مي  •
 . كند 
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 L Toolنمونه .  از آرايه ايجاد مي كند  ()index درL Tool Boxنمونه جديد از كلاس سراسري  سپس يك  ،مولفه •

Box داده با استفاده از نامهاي خصوصيت از قبل تعريف شده .  يك مكان ذخيره سازي براي همه داده هاي تعامل مي باشد
 . تنظيم مي شود و يا از نمونه بازيابي مي شود 

 از  Index 1 در L Tool Box global class ، آن مولفه تعامل يك نمونه مي رود به تعامل دوم Timelineوقتي  •
Session Array  ايجاد مي كند. 

  از Index 2 در L Tool Box global classآن مولفه تعامل يك نمونه  به تعامل سوم مي رود ، Timelineوقتي  •
Session Arrayاين كار با .   ايجاد مي كندIndex 3 ، Index 4ا زمانيكه همه تعاملات در يك  و الي آخر ادامه پيدا مي كند ، ت

Index قرار بگيرند . 

در پايان مجموعه تعاملات ، همه داده هاي پردازش شده در بين آن تعاملات در دسترس و سازماندهي شده هستند  •
. 

  . به شكل مشابهي در تعاملات تكي و تعاملات آزمون استفاده مي شود Session Array: نكته 
  استفاده هاي ممكن

كه نياز دارند تعاملات را رديابي و يا تحليل كنند ، مثل ايجاد محيط هاي  يعات بيشتر براي توسعه دهندگاناين اطلا
  .  مفيد است macromedia flashآزمون شخصي و ايجاد آزمونهايي در يك قالب متفاوت از روي الگوهاي آزمون 

    Session Arrayمشخصات رديابي قابل دسترس در 
.  مراجعه مي كند LMS در  SCORM و هم AICCبه مقادير رديابي تعامل استاندارد براي هم نامهاي خصوصيات 

  :شما مي توانيد يك خصوصيت تعامل را با استفاده از رجوع به محل آن در دستور زير بازيابي كنيد 
SessionArray[n].[property_name]  

امل شماره يك ، شما مي توانيد از دستور زير استفاده كنيد  براي تعinteraction_IDبراي مثال ، براي رجوع به مقدار 
:  

SessionArray[0].interaction_ID  
  :براي رجوع به مقدار نتيجه در تعامل شماره دو ، شما مي توانيد از اين دستور استفاده كنيد 

SessionArray[1].result  
  نامهاي از قبل تعريف شده براي خصوصيات 

  :بل تعريف شده براي خصوصيات را توصيف مي كند جدول زير نامهاي از ق
  

  توصيف  نام خصوصيت
interaction_ID  نام منحصربفرد تعامل  

interaction_type  نوع تعامل  
objective_ID  شماره شناسايي خارجي  

weighting   بعضي از تعاملات مي توانند وزن بيشتري . مقدار وزن براي اين نمونه تعامل
  . ديگر داشته باشند نسبت به تعاملات

correct_response  قالب بندي صحيح پاسخ برگردانده شده از پارامترهاي كاربر  
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student_response قالب بندي پاسخ برگردانده شده دانش آموز از ارزيابي  
result  نتيجه ارزيابي  

latency  زمان تلف شده در طول اين بخش از تعامل  
dateStamp  خ داده استتاريخي كه تعامل ر  
timeStamp  ساعتي كه تعامل آغاز شده است  

  
  . قابل دسترس مي باشد Session Array در هر ايندكس L Tool Boxهمه روشها و خصوصيات  كلاس سراسري 

    ها و مولفه هاي تعامل آموزشيScriptساختار اصلي 
 مي شوند ، حالا اطلاعات كمي درمورد گرد ياد گرفتيد چگونه داده هاي يك تعامل ذخيره و بازيابي اكنون كه شما 

آنها پارامترهاي كاربر را جمع آوري مي . مولفه هاي تعامل آموزشي واقعا قلب كل ساختار هستند . كردن تصوير مي دهيم 
اربر براي آنكه ، آنها پارامترهاي ك.  مي سازند  و توابع دستكاري وقايع را در سطح ابزارهاي تعاملSession Arrayكنند و 

اگر شما بخواهيد چگونگي اين كار را آزمايش كنيد ، . را قبول مي كنند و محيط را و در نتيجه ابزارها را پيكربندي مي كنند 
  . را در پانل كتابخانه باز كنيد Scriptشما نياز خواهيد داشت كه 

  است ، كه ما به آن قبلا به آن  L Tool Box global classاول .  ها در يك يا دو مكان قرار گرفته اند Scriptاكثر 
 دوم در Script. ذخيره سازي داده  را پردازش مي كند و داده را براي تعامل قالب بندي مي كند  Scriptاين .اشاره كرديم 

 شده  ها توابع دستكاري وقايع را كه به وسيله ابزارهاي تعامل راه اندازيScriptاين . بين هر مولفه تعامل قرار گرفته است 
مكاني وجود دارد كه پارامترهاي كاربر و ابزارهاي تعامل مقداردهي اوليه مي شوند و تعامل . اند ، مقداردهي اوليه مي كنند 

آنها در سطح مشابهي با  در سطح مولفه ساخته مي شوند ،  ها Script اين با اينكه.  ها را ارزيابي مي كند Scriptموقعيت 
  .   در سطح ابزارهاي تعامل پيشنهاد مي كنند Session Arrayي اوليه مي شوند و داده ها را به ابزارهاي تعامل  مقدار ده
 و درپوشه L Tool Box global class ها را ببينيد و يا به آنها اضافه كنيد ، در كتابخانه به Scriptاگر شما بخواهيد 

 Script به بخشهاي توضيحات كه در قسمت بالاي Scriptر ه.  هر مولفه تعامل آموزشي مراجعه كنيد Scriptمولفه ها براي 
 در داخل توابعي ساخته شده اند تا پيمانه اي بودن رعايت شود Scriptاغلب بخشهاي . توصيف شده است تقسيم شده است 

.  
   Nextتغيير متن دكمه 

متن پيشفرض براي . را تغيير داد  ها Script مثالي است براي اينكه شما ببينيد چگونه مي توان Nextتغيير متن دكمه 
 L براي دكمه Action Script يا هر متن ديگري ، از Nextبراي تغيير آن به .  مي باشد Next ، Next Questionدكمه 

Tool Box استفاده كنيد    .  
   :Nextبراي تغيير متن دكمه 

  و بعد كليپ فيلم LGlobalClass_1، سپس پوشه  ) Window>Library(  پانل كتابخانه را باز كنيد -1

LGlobalClass را باز كنيد .  
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  . كليك كنيد Find buttonو سپس روي  ) Window>Actions( را باز كنيد Actions پانل -2
  . كليك كنيد Find Next را تايپ كنيد و سپس روي Find ، Next Questionدر پانل  -3
  

  
  
  .نمايش داده شود تغيير دهيد  متن را به متني كه مي خواهيد براي دكمه -4
  

  
  

  Next Questionاولين رويداد 
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.  پيدا شود و آنها را تغيير دهيد Next Question كليك كنيد تا رويدادهاي بعدي Find Next ، روي Findدر پانل  -5
  . دارد تغيير مي دهد Next Questionتغيير اين دو رويداد هر نمونه اي را متن 
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